ゲーム開発、イラスト、KAORAEntertainmentBLOG

It is a blog about KAORAEntertainment game 自作ゲームの情報や作成進捗状況です

【unity】「Google play 64bit要件に準拠していません」の対処法

Google Play Consoleで「64bit要件に準拠していません」エラーがでる

googleplayにapkをアップしようとしたところ、下記のようなメッセージが表示された。

f:id:KAORA_22:20190830005446p:plain

f:id:KAORA_22:20190830005449p:plain

 

ん?

unityで64bitビルドしているのにな。。

 

解決策は簡単でした。

「x86」のチェックを外すことで解決

f:id:KAORA_22:20190830005453p:plain

Unityのplayersetting 内のx86のチェックを外して、再ビルドし作成したapkを登録すると解決。たったこれだけです。

 

f:id:KAORA_22:20190908181429p:plain




消えました。

 

32bit端末にはインストールできなくなるけど、大丈夫?

32bit端末にインストールできなくなれば、ダウンロード数が減ることにつながるのでは?と思い、32→64bitオンリーのapkをアップした際のサポート端末の変化を見てみました。

f:id:KAORA_22:20190908181434p:plain

 

サポート対象外になった端末はスマホなら1でした。

ウェアラブルは5

まさか、対象外の1つのAndroidスマホがめちゃくちゃ売れているとも考えにくいので、全く気にする必要がなさそうです。